解决升级到python3 yum不能使用的问题




1.修改yum配置文件(vi /usr/bin/yum)。

把文件头部的#!/usr/bin/python改成#!/usr/bin/python2.7。

2.修改 /usr/libexec/urlgrabber-ext-down 文件,将python同样指向python2.7

因为yum是基于Python编写的,而Python3和Python2有部分语法是不同的

搜索博客

常用标签